notehub.io and Notehub API down; other services may be degraded

Incident Report for Blues

Postmortem

Last night’s outage was caused by a default OS upgrade automation. While each Notehub infrastructure service is supported by multiple, redundant server instances, the automated upgrade incorrectly impacted multiple servers at the same time. This caused some key services used by the UI and API to go offline.

To insure the issue doesn’t recur, we have disabled this default automation. Then, to ensure we still maintain our OS, we will implement a custom OS upgrade automation to prevent redundant server instances going offline at the same time.

Posted Jul 15, 2025 - 17:07 EDT

Resolved

The incident was resolved as of 3:43AM ET.
Event routing was not impacted. Only access to notehub.io and api.notefile.net
Posted Jul 15, 2025 - 04:33 EDT

Update

Services appear to be returning to normal, but we are continuing to investigate.
Posted Jul 15, 2025 - 03:56 EDT

Investigating

Notehub.io and the Notehub API are currently unavailable.
Event routing appears to be working.
The incident started at 2:41AM.
We will publish further updates as we learn more.
Posted Jul 15, 2025 - 03:52 EDT
This incident affected: Notehub API and notehub.io UI.